[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Condor-users] condor on windows server 2003


I have a dedicated pool of 14 compute nodes all of which are running Windows 2003 Server. I had the same problem until I added the condor-reuse-vm? user to the administrator's group.  After that, things worked fine.  If you look in the starter log, you will see " Create_Process: CreateProcess failed, errno=5" which is the WIN32 error "Access is denied."

I also experienced this problem on 1 out of 3 (approximately) of my Windows XP machines.  I'm at a loss to explain why the default installation worked on some machines and not others since every one of my workstations is built from the same standard RIS deployment image.

I started with v.6.6.6 on my execution nodes.  Since then, the entire pool was upgraded to v6.6.7.  These versions will work on Windows 2003 Server.

In my configuration, I created a domain user called CONDOR and specified jobs to run using MYDOMAIN\CONDOR as a dedicated user.  I configured my execution nodes to use MYDOMAIN\CONDOR in lieu of condor-reuse-vm?.  This allows my jobs to access domain network shares at runtime.  Note that this is also a potential security hole depending on the permissions you give to CONDOR.  In my case, I had to make CONDOR an administrator on all the compute nodes just to get things to run.  I was assured by folks at the cs.wisc that this shouldn't be necessary but I just can't get it to run otherwise.


-----Original Message-----
From: condor-users-bounces@xxxxxxxxxxx [mailto:condor-users-bounces@xxxxxxxxxxx] On Behalf Of Oliver Hotz
Sent: Thursday, December 02, 2004 10:23 AM
To: 'Björn Baumeier'; 'Condor-Users Mail List'
Subject: RE: [Condor-users] condor on windows server 2003

I put up some more information


here you can find the log files.. maybe somebody can make something of it.

It is matching the Winnt52 correctly

-----Original Message-----
From: Björn Baumeier [mailto:baumeier@xxxxxxxxxxxxxxxxxxx] 
Sent: Wednesday, December 01, 2004 11:43 PM
To: oliver@xxxxxxxxxxxx; 'Condor-Users Mail List'
Subject: AW: [Condor-users] condor on windows server 2003

Hello Oliver!

We are running a Windows 2003 Server in terminalserver mode to function as
central submit node in our pool. The condor version we installed is 6.6.6
and things are working fine without any additional settings. However, since
we don't use the server as a compute node, I can't tell if there is any
trouble with that. 

Can you submit jobs from the server to other node in the pool? 
If you try to submit to the server, what does "condor_q -analyse" produce?
If I am not completely wrong, Windows Server 2003 has "OpSys=WINNT52"
whereas a Windows XP system has "OpSys=WINNT51". So maybe no match has been


Björn Baumeier		baumeier@xxxxxxxxxxxxxxxxxxx
Universität Münster
Institut für Festkörpertheorie
Wilhelm-Klemm-Strasse 10
D-48149 Münster
Tel. +49 251 83 - 33583
-----Ursprüngliche Nachricht-----
Von: condor-users-bounces@xxxxxxxxxxx
[mailto:condor-users-bounces@xxxxxxxxxxx] Im Auftrag von Oliver Hotz
Gesendet: Donnerstag, 2. Dezember 2004 03:24
An: 'Condor-Users Mail List'
Betreff: [Condor-users] condor on windows server 2003

Hey guys..

I am having some extreme problems with getting condor to run on windows
server 2003.

I know its probably some sort of permissions or security policy thing, but I
just don`t know what.

I installed everything on windows xp pro, and a simple .bat file (creating
an empty text document on c:\) works just fine.

However, when I try to do the same thing on windows server 2003, same condor
config, same installation, the file never gets written to c:\.. neither do I
get a error log or output log for that .sub/bat file.

Any ideas ?.. anyone that has gotten condor to work on windows 2003 server
and knows its working ?.. what kind of security policies did you change, etc
?.. I really thought I have tried everything possible.. I just can't think
of anything... this is with condor 6.7.2


Condor-users mailing list

Condor-users mailing list