[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Condor-users] Condor-G and WS-GRAM


I am trying to figure out what I am doing wrong.

I am running Condor 6.7.14, and Globus 4.0.1. I am trying to submit a job from one machine using Condor-G and have it run on another machine via ws-gram.

My submit script looks like:

executable = env-test.pl
globusscheduler = compute1.ncsa.uiuc.edu:8443
universe = grid
grid_type = gt4
environment = foo=bar; zot=qux
output = ws-test.out
log = ws-test.log

In my log file I see:
000 (1034.000.000) 02/22 07:39:10 Job submitted from host: <>
012 (1034.000.000) 02/22 07:39:15 Job was held.
     Failed to initialize GAHP
     Code 0 Subcode 0

If I run prettu much the same thing using pre-wsgram:
executable = env-test.pl
globusscheduler = compute1.ncsa.uiuc.edu/jobmanager-fork
universe = grid
grid_type = gt2
environment = foo=bar; zot=qux
output = env-test.out
log = env-test.log

It works just fine.

If I run a straight globusrun-ws:
globusrun-ws -F compute1.ncsa.uiuc.edu:8443 -submit -streaming -c /bin/hostname

That works fine too.

What am I doing wrong?  What don't I have configured correctly?