[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Condor-users] Condor Job execution problem


I am trying to submit a job on Linux machine. The job fails and the .err file says it couldn’t find the executable. I am for sure; the executable is transferred to the execution node. Basically I am creating a compressed tar file which has all the input files, data files and executable. In the same way I am running other jobs, those are running fine and I am having problem with only this. Is it some environment is missing, even then it shouldn’t say it couldn’t find or open the file right. Even I tried with adding getenv=True to see whether it works but no luck.


Here is the job description.


universe = vanilla

executable = first

Arguments = run1.tgz

getenv = True

output = first.out

error = first.err

log = first.log

should_transfer_files = YES

when_to_transfer_output = ON_EXIT

transfer_input_files = run1.tgz






/usr/local/condor/condor-6.6.10/local.pittgrid/execute/dir_3460/condor_exec.exe[3]: .: testcase4.x: cannot open [No such file or directory]




It displays all the file it untar and I am seeing the testcase4.x file.


I tried with directly adding the executable in the transfer_input_files but still didn’t work.


Could you please let me know what might be the problem.