[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Condor-users] Job not running

 I have a C++ program that uses STL. I tried condor_compile and g++ version 3.4.6 to compile this code to
generate a condor checkpointable executable, but it gave all sorts of error messages saying the STL
functions are all undefined. I tried g++ version 3.2.2, still with no luck. Then I tried version 4.1.2-42, and
it worked. But the problem I am facing is, this executable runs fine when I run it from command prompt.
But when I submit it as a condor job, the job finishes within one second, and does not produce and error
or any output. I guess is that condor failed to run the executable at all? What could be the reason for this?
I am submitting the job to execute in the same machine where I built the executable with version 4.1.2.
Is it possible that condor has any other version of gcc set as default? Or anybody has any idea?


Tanzima Zerin Islam
Graduate Student
School of Electrical & Computer Engineering
Purdue University