[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Condor-users] Error when running condor_master


We are trying to install condor version 7.4.2 and we ran into the
following errors when we tried to run condor_master as root:

1.First we tried to install condor in a machine with Ubuntu 10.04 LTS.
Although we had placed condor_config file in the ~condor directory
(which is a shared directory based on nfs), the command condor_master
returned the error message:

 "Neither the environment variable CONDOR_CONFIG,
/etc/condor/, nor ~condor/ contain a condor_config source.
Either set CONDOR_CONFIG to point to a valid config source,
or put a "condor_config" file in /etc/condor or ~condor/

We then defined the environment variable CONDOR_CONFIG and
condor_master was able to find the condor_config file, but this is not
the most convenient way for us. Does anyone have an idea why placing
the file in ~condor didn't work?

2. After that we ran into another error that we were not able to solve:
"ERROR: the uid specified in CONDOR_IDS config file variable (1149)
does not exist in your password information.
Please set CONDOR_IDS to the '.' seperated uid, gid pair that
should be used by condor."

We can not understand why this happens because in /etc/passwd we have
user "condor" defined.

3. We then tried to make the installation in a machine with Fedora
Core 7, which had been working with an older version of condor (6.8).
Again, we got the error described in point 1 and we defined the
CONDOR_CONFIG variable. Then, we ran into a new error:

"ERROR "gethostbyname(simul01.itqb.unl.pt) failed, errno = 0" at line
187 in file my_hostname.cpp"

We have checked our /etc/hosts and we can't find anything strange, but
we are a bit lost because we don't know what to look for. We also
tried to run nslookup and there was no problem. Has anyone ran into
this and was able to solve it?

Thanks in advance

Diana Lousa

Diana Lousa
PhD student
Protein Modeling Laboratory
Oeiras, Portugal