[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] ERROR starting condor_master

Hi Michael,
some comments that maybe help you:
  1. Ubuntu is Debian-like not RedHat-like, so you should download the:
    condor-7.4.4-linux-x86_64-debian50-dynamic.tar.gz or the condor-7.4.4-linux-x86-debian50.tar.gz
    this are build for Debian like operating systems.
  2. The /root folder is access protected in Linux (security reasons) so that's the worse place to install a package, I usually install it in /opt or /home  or even /home/condor. No matter where you install it, the parent folder sould have rwxr-xr-x access rights (chmod 755 /opt or /home or whatever)
  3. In the command line you wrote, there's not --owner (and if you are installing as root, you must define an owner other than root (condor's user is a good choice)
  4. After installation you can start condor as root (condor_master), condor will change to condor's user.

Bye, I hope this help you.

On Tue, Nov 9, 2010 at 2:06 PM, Michael Grauer <michael.grauer@xxxxxxxxxxx> wrote:
I've downloaded the condor-7.4.4-linux-x86_64-rhel5-dynamic.tar.gz on Ubuntu 10.10, and when I attempt to start condor_master, none of the other daemons will start.

I've created a condor user, and installed with the
--prefix=/root/condor --local-dir=/home/condor/localcondor

When I run condor_master as condor, I get errors in the MasterLog that say:

"11/09 13:00:06 /root/condor/sbin/condor_startd: Cannot execute
11/09 13:00:06 restarting /root/condor/sbin/condor_startd in 13 seconds
11/09 13:00:06 attempt to connect to <> failed: Connection refused (connect errno = 111)."

and similar for the other daemons.

When I run condor_status I get:

"Error: communication error
CEDAR:6001:Failed to connect to <>"

I have also followed the Newer Unix Installation Procedure in the manual (section 3.2.3), installing and running as root, with the same result.

When I run the condor_install script, I do get the following warning:

"WARNING: Multiple network interfaces detected. Condor might not work properly until you set NETWORK_INTERFACE=<interface IP>."

I have set this property in condor_config to my IP, and that doesn't resolve the issue.

Any help or guidance is appreciated.

Condor-users mailing list
To unsubscribe, send a message to condor-users-request@xxxxxxxxxxx with a
subject: Unsubscribe
You can also unsubscribe by visiting

The archives can be found at:
Edier Alberto Zapata Hernández
Est. Ingeniería de Sistemas
Universidad de Valle