[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] standard universe jobs won't start but vanilla are OK

> -----Original Message-----
> From: condor-users-bounces@xxxxxxxxxxx [mailto:condor-users-
> bounces@xxxxxxxxxxx] On Behalf Of Todd Tannenbaum
> Sent: 22 November 2011 20:41
> To: Condor-Users Mail List
> Subject: Re: [Condor-users] standard universe jobs won't start but vanilla
> are OK
> Ian Cottam wrote:
> > Don't shell scripts give problems in Standard?
> > I just tried on our pool and got "job not properly linked for Condor".
> > -Ian
> >
> >
> Yes, Condor will confirm that the executable has been re-linked with the
> condor_compile command.
> If you want to submit a script to standard universe, you can do so, but
> there are some limitations.  See the "allow_startup_script" option
> documented in the condor_submit man page, online at
>    http://research.cs.wisc.edu/condor/manual/v7.6/condor_submit.html

I've just compiled and linked a "hello world" C code with condor_compile
and I get exactly the same thing - it runs OK under vanilla but doesn't
seem to start under standard universe. I noticed this in startd log

 Job wants old RSC/Ckpt starter, skipping /usr/sbin/condor_starter

Is this relevant ? Also whenever I run the code I get this error:

Condor: Notice: Remote system calls disabled.

Which sounds serious ???