[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[HTCondor-users] cannot create directory `/etc/condor/local/run/condor'

Hi. I just installed condor on my Ubuntu 12.04 using the debian package.

>> deb http://research.cs.wisc.edu/htcondor/debian/stable/ lenny contrib

I then performed apt-get update and install. 

I wanted to reconfig but condor wasn't running (as indicated by Can't find address for local master), and when I tried to start the service, I got the following errors:

vagrant@precise32:/etc/condor# sudo service condor start
vagrant had uid 1000
mkdir: cannot create directory `/etc/condor/local/run/condor': No such file or directory
chown: cannot access `/etc/condor/local/run/condor': No such file or directory
FATAL: Required directory /etc/condor/local/run/condor does not exist, or is not a directory.

vagrant@precise32:/etc/condor$ ls -la
total 128
drwxr-xr-x  3 30101 30101   4096 Jan 10 23:35 .
drwxr-xr-x 97 root  root    4096 Jan 10 23:21 ..
-rw-r--r--  1 30101 30101 110757 May  9  2012 condor_config
-rw-r--r--  1 root  root    1693 Jan 10 23:24 condor_config.local
drwxr-xr-x  2 30101 30101   4096 May  9  2012 config.d

It is not clear to me where have I gone wrong with my setup. Besides, I noticed that weird 30101 group and user. Any idea? 
In the previous setup, we download the tar.gz and supply --owner and it went fine. 
I am not even able to remove and purge this condor right now. When ubuntu tries to remove condor, it hits the same error.

Any help is appreciated.