[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [HTCondor-users] htcondor 8.4 rpm issues

Salut Brian,


I donât see any condor (anymore ?) in epelâ ?





De : HTCondor-users [mailto:htcondor-users-bounces@xxxxxxxxxxx] De la part de Brian Bockelman
Envoyà: vendredi 13 novembre 2015 13:52
à: HTCondor-Users Mail List <htcondor-users@xxxxxxxxxxx>
Objet : Re: [HTCondor-users] htcondor 8.4 rpm issues


Hi Frederic,


I think this was fixed in the EPEL build of Condor.  Can you try that?


If so, I'm sure the change can be upstreamed to the UW release.



Sent from my iPhone

On Nov 13, 2015, at 4:36 AM, SCHAER Frederic <frederic.schaer@xxxxxx> wrote:



Iâm trying to upgrade a grid system wich contains EMI/UMD softwareâ and things are getting wrong.

Iâm getting :


Error: Package: glite-wms-brokerinfo-access-3.5.0-3.sl6.x86_64 (@irfu-emi3-base)

           Requires: libclassad_ns.so.1()(64bit)

           Removing: classads-1.0.10-1.el6.x86_64 (@epel)


           Obsoleted By: condor-classads-8.4.0-1.el6.x86_64 (htcondor-stable)

               Not found

Error: Package: glite-lb-common-9.1.1-1.el6.x86_64 (@epel)

           Requires: libclassad.so.1()(64bit)

           Removing: classads-1.0.10-1.el6.x86_64 (@epel)


           Obsoleted By: condor-classads-8.4.0-1.el6.x86_64 (htcondor-stable)

               Not found

           Available: condor-7.6.4-1.x86_64 (htcondor-stable)


           Available: condor-7.6.5-1.x86_64 (htcondor-stable)


           Available: condor-7.6.6-1.x86_64 (htcondor-stable)


           Available: condor-7.6.7-1.x86_64 (htcondor-stable)


           Available: condor-7.6.8-1.x86_64 (htcondor-stable)


           Available: condor-7.6.9-1.x86_64 (htcondor-stable)


           Available: condor-7.6.10-1.x86_64 (htcondor-stable)


           Removing: condor-8.2.8-313322.x86_64 (@htcondor-stable)

               Not found

           Updated By: condor-8.4.0-1.el6.x86_64 (htcondor-stable)

               Not found

           Available: condor-7.8.0-37683.x86_64 (htcondor-stable)

               Not found

           Available: condor-7.8.1-43996.i386 (htcondor-stable)

               Not found



My question therefore is : how should things be upgraded ?

Should condor be kept in a 8.2 version on the startd only ?


From what I understand, the new condor packages obsolete previous functionalities without being backward compatible with dependent softwareâ

I checked and the condor-classads RPM effectively obsoletes :

classads <= 1.0.10

classads-static <= 1.0.10


But nothing provides âlibclassad_ns.so.1()(64bit)or libclassad.so.1â


Why prevent the other non-conflicting RPMs in epel from being installed if thatâs breaking things ?

Any idea how I should update the system, but more important : how can I make sure that further node reinstallations wonât break because the new condors are not compatible with whatâs published in epel ?

I could off course blacklist condor 8.4 in yum, but Iâd like to avoid messing with temporary (?) things which will break with next releasesâ and I donât see why 8.4 could not be installed in parallel of the old âclassadsâ rpm ?



HTCondor-users mailing list
To unsubscribe, send a message to htcondor-users-request@xxxxxxxxxxx with a
subject: Unsubscribe
You can also unsubscribe by visiting

The archives can be found at: