[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [HTCondor-users] $(FULL_HOSTNAME)


Thanks for the information. I will use it to investigate further when I next have the time. One problem I ran into is that out-of-the-box that Openstack does not automatically set the hostname of an instance to the default internal/private DNS name of the instance that can be resolved. But I'm not sure why RHEL7 handles this better out-of-the-box than RHEL6. It must be something in the default networking configuration somewhere. If I find the answer, I'll post it here. 


From: HTCondor-users [htcondor-users-bounces@xxxxxxxxxxx] on behalf of Todd Tannenbaum [tannenba@xxxxxxxxxxx]
Sent: Tuesday, November 29, 2016 12:01 PM
To: HTCondor-Users Mail List
Subject: Re: [HTCondor-users] $(FULL_HOSTNAME)

On 11/28/2016 5:39 PM, Kandes, Martin wrote:
> Hi HTCondor team,
> How does HTCondor determine $(FULL_HOSTNAME)? Is there a difference in
> how it is determined between EL6 and EL7? I ran into a problem with a
> simple, out-of-the-box personal condor pool install not working on EL6
> [1] [2], but it is working with no problem on EL7 [3] [4].
> I know the problem has something to do with how the local system is
> configured. The problem occurs on a CentOS 6 image booted up on a local
> OpenStack cluster. However, the error is not observed when I perform the
> same install on a CentOS 6 image on AWS.
> This is not an urgent matter. But when you get the chance, perhaps you
> can provide a possible explanation. I'd like to understand better what
> maybe causing the difference in behavior.
> Thanks,
> Marty

Hi Martym

Unfortunately, the answer is complicated, it is different depending upon
the version of HTCondor (because things had to change to support IPv6),
and is dependent on settings you may have tweaked such as

 From my dim memory (warning! this is off the top of my head...), the
basic idea is HTCondor figures out which network interface it will use
by default (see docs for NETWORK_INTERFACE), and then does an
inverse-lookup on the IP address associated with that interface to get a
fully qualified hostname.  Perhaps your openstack cluster is not setup
with inverse address names in DNS, but AWS is?  Failure to setup inverse
address names is a common site failure, esp if the site recently
deployed IPv6. As for why RHEL7 works on openstack, perhaps your RHEL7
image is configured to fallback on using /etc/hosts to do inverse lookup
via nsswitch.conf. What does your host file look like on the two images?
  According to the standards it should be
   address full.hostname.edu alias1 alias2
e.g. the fully qualified hostname should appear first:
GOOD:  chevre.cs.wisc.edu chevre
  BAD:  chevre chevre.cs.wisc.edu

You can gather some insight into what is going on by doing (on bash)

   %  _condor_tool_debug=D_HOSTNAME condor_config_val -debug full_hostname

or if you are running a more recent HTCondor v8.5.x, you could do
   % condor_config_val -debug:D_HOSTNAME full_hostname

hope the above helps,

HTCondor-users mailing list
To unsubscribe, send a message to htcondor-users-request@xxxxxxxxxxx with a
subject: Unsubscribe
You can also unsubscribe by visiting

The archives can be found at: