[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[HTCondor-users] Docker Universe and Local scripts

Hi All,

I'm running some early tests with docker universe to see if its viable to suggest to my users, and I'm running into some trouble. If I work off of command that are strictly in the image itself everything is fine, but if the "executable" is set to a local script, the job is held with the following:

"Hold reason: Error from slot1_1@xxxxxxxxxxxxxxxxx: Error running docker job: OCI runtime create failed: container_linux.go:348: starting container process caused 'exec: \'./condor_exec.exe\': stat ./condor_exec.exe: no such file or directory': unknown"

I'm using the following submit file:
>universeÂÂÂÂÂÂÂ = docker
>ExecutableÂÂÂÂÂ = ./dockertest.sh
>docker_imageÂÂÂ = debian
>LogÂÂÂÂÂÂÂÂÂÂÂÂ = test.log
>OutputÂÂÂÂÂÂÂÂÂ = test.out
>ErrorÂÂÂÂÂÂÂÂÂÂ = test.error
>request_memory = 512

ÂI have tried adding:
>transfer_executable = True

or (based on: https://research.cs.wisc.edu/htcondor/HTCondorWeek2015/presentations/ThainG_Docker.pdf)
> transfer_input_files = dockertest.sh


>input_files = dockertest.sh

I'm sure this is probably something i'm being dumb about, but I'm not overly experienced with using docker so I'm feeling a bit lost. If it ends up being important dockertest.sh is just a simple bash script that runs "echo 'this worked'"

any help would be appreciated.