[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [HTCondor-users] docker detection broken in centos 7

On 10/31/2019 4:21 PM, Todd Tannenbaum wrote:
On 10/31/2019 1:23 PM, Dimitri Maziuk via HTCondor-users wrote:

10/31/19 13:08:39 (pid:1798) '/usr/bin/docker info' did not exit successfully (code 256); the first line of output was 'WARNING: Error loading config file: /root/.docker/config.json: stat /root/.docker/config.json: permission denied'.

Strange!  Esp since you tried 'docker info' as user 'condor' and all was
well (this is what I was going to suggest first, but you beat me to it!).

Perhaps the interesting part of the error from docker may be after the
first line....  I am guessing the part about config.json is a red herring.

Not entirely: I tried making the directory and touching the file on one node, the error went away and docker was detected. It still doesn't explain why other nodes work fine without it. This is happening after condor_reconfig and/or restart with docker already running so systemd races are not the cause here. (Though they may exist on reboot, too.)

I'll try to debug later today and report back