[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[HTCondor-users] Condor_master aborting because of FIPS mode

I am attempting to get Condor (8.8.9) setup and configured on a new machine running RHEL 7.7. Presently this machine is the only machine in the pool. (More machines are planned on being added later once this machine gets up and running.) Anyway, I “installed” Condor (8.8.9) from a tarball and modified the Condor configuration files to be somewhat similar to our current (but older) setup of Condor on a different network. At the moment I am attempting to start condor_master manually (as root via sudo) to get it debugged before  trying to get it to start as a service. I am currently at the point, where, when  attempting to start it, I am getting the following fatal error:


md5_dgst.c(82): OpenSSL internal error, assertion failed: Digest MD5 forbidden in FIPS mode.


I’m told that disabling FIPS mode is unlikely to be an option. While there are no specific SEC_* macros being set in the configuration files I am using, I tried setting a few SEC_DEFAULT_* ones to False to see if that would work. However, I am still receiving the same error. Thoughts/suggestions of what to look at next?