[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[HTCondor-users] Broken rpm dependencies hamper installation of older 9.0.x releases

Dear all,

parts of our systems at GridKa use a fixed HTCondor version to avoid automated updates by our puppet configuration management. While re-deploying one of that nodes, we figured out the following problem. The HTCondor version was fixed to 9.0.9-1.el7 and the command yum install condor-9.0.9-1.el7 failed due to dependencies problems. The reason is that condor-9.0.9-1.el7 requires python{2,3}-condor without a specific version. yum is then using the latest version, which however requires a specific condor version, in that case condor-9.0.12-1.el7.

Is this intended behavior or a bug in the packaging procedure?

Steps to reproduce:

yum install epel-release
yum install https://research.cs.wisc.edu/htcondor/repo/9.0/htcondor-release-current.el7.noarch.rpm

yum install condor-9.0.9-1.el7 -> Fails!

yum install condor-9.0.9-1.el7 python2-condor-9.0.9-1.el7 python3-condor-9.0.9-1.el7 -> Works!

The reason is 

rpm -q --requires condor-9.0.9-1.el7 | grep python
python2-condor -> no version
python3-condor -> no version

rpm -q --requires python2-condor |grep condor
condor = 9.0.9-1.el7

Thanks and best regards,

Dr. Manuel Giffels, Karlsruhe Institute of Technology (KIT), Steinbuch Centre for Computing (SCC)
Hermann-von-Helmholtz-Platz 1, 76344 Eggenstein-Leopoldshafen
Phone: +49 721 608 28636, Email: Manuel.Giffels@xxxxxxx

Attachment: smime.p7s
Description: S/MIME cryptographic signature