[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [condor-users] Master-Worker installation problems

Hello Guy,

There is also an MW mailing list, and I am also forwarding my response
to that list...

On Fri, 2004-05-28 at 13:10, Guy Tel-Zur wrote:
> I tried to install MW without success:
> After  executing "./configure" I got:
> nm: /lib/libcondorsyscall.a: No such file or directory
> So, I tried to add --with-ldflags="-L/unsup/condor/lib" or setenv 
> LDFLAGS "-L/unsup/condor/lib"
> But it didn't solve the wrong search path. Finally it was solved by adding:
> "setenv CONDOR_DIR /unsup/condor" which is not documented in the INSTALL 
> file!

Yikes!  Thanks for reporting this.
Actually you uncovered a bug in the configure script.
CONDOR_DIR is supposed to be set automatically in the configure script.
I'll check in a fix right now, and tarballs will be updated soon.
(There is also a --with-condor option to configure).

> Then, I noticed this message:
> -- You don't have fork capable condor_compile version, won't use NWS.
> What does it mean? and how to correct it?

Here the 'NWS' stands for "network weather service".  I think I will
also remove this option from the configure script for the time being,
since the NWS features aren't used by the versions of MW that we
distribute.  So soon this "error message" (really just a warning
message) will go away.

> Then, "make" passed ok but "make check" failed with these errors:
> ....
> /unsup/condor/lib/libc.a(nsswitch.o)(.data+0x20c):/home/condor/execute/dir_30197/condor6.6.5/externals/build/glibc- 
> undefined reference to `_nss_files_endspent'
> /unsup/condor/lib/libc.a(nsswitch.o)(.data+0x214):/home/condor/execute/dir_30197/condor6.6.5/externals/build/glibc- 
> undefined reference to `_nss_files_setspent'
> /unsup/condor/lib/libc.a(nsswitch.o)(.data+0x21c): In function 
> `__nss_configure_lookup':
> /home/condor/execute/dir_30197/condor6.6.5/externals/build/glibc- 
> undefined reference to `_nss_files_getspnam_r'
> collect2: ld returned 1 exit status
> make[2]: *** [masternewmatmul_file] Error 1
> make[2]: Leaving directory `/scratch/mw/examples/newmatmul'
> make[1]: *** [check] Error 2

> I use:
> $CondorVersion: 6.6.5 May  3 2004 $
> $CondorPlatform: I386-LINUX-RH9 $
> from ron.cs.wisc.edu, and the latest MW from the website: 
> http://www.cs.wisc.edu/condor/mw
> I would appreciate any help.

I think there are some problems with MW-File communication layer and the
more recent version(s) of Condor and glibc.  Perhaps someone from the
Condor team can enlighten us as to these link errors.

(I tried also linking in the libraries...  condor/lib/libnss_files.a,
and a few others and I still couldn't get the MW-Files based executables
to link)...

Thanks for your interest in MW and for reporting your hardships.
Hopefully, we can have a good answer to the MW-files linking problem
soon.  The Condor-pvm based version should hopefully be working OK for


Jeff Linderoth				     O: 610-758-4879
Asst. Professor				     
Industrial and Systems Engineering	     jtl3@xxxxxxxxxx
Lehigh University			www.lehigh.edu/~jtl3          

Condor Support Information:
To Unsubscribe, send mail to majordomo@xxxxxxxxxxx with
unsubscribe condor-users <your_email_address>