[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Condor-users] Condor and batch Matlab problem

It could be a security/permissions thing. We had this happen on another matlab-like program. Every time it ran it wanted to update a file in the install directory. However, without modification the default condor local account did not have permission to update this file. So, run matlab interactively and look for recently modified files in the matlab install directory. Give update permissions to the local condor account for those files and see if that fixes your issue. ~B

-----Original Message-----
From: condor-users-bounces@xxxxxxxxxxx [mailto:condor-users-bounces@xxxxxxxxxxx] On Behalf Of Gabriel
Sent: Wednesday, July 14, 2004 1:27 AM
To: condor-users@xxxxxxxxxxx
Subject: [Condor-users] Condor and batch Matlab problem


 I am trying to run a matlab job on a Condor pool. The execute machine I use for testing is running Win XP, Condor 6.6.5 and Matlab 6.5.

 After submission, the job enters the running state and
hangs. I don't think the script is even started, as no result file is produced.

 I am using a very simple matlab script file. test.m:

load a.dat;
load b.dat;
matrR = a * b;
save matrR.dat;

 The script runs ok when I run it locally.

 When I submit through condor, I use a matlab.bat file, with the content

matlab.exe %1 %2 %3 ... which calls the matlab engine on the

execute machine so I don't have to stage the executable.

 The condor submit script is 

# Submit a matlab job
Executable = matlab.bat
Universe = vanilla
Requirements = ((Arch == "INTEL" && OpSys == "WINNT51")) should_transfer_files = YES whenToTransferOutput = ON_EXIT transfer_input_files = a.dat,b.dat,test.m environment = PATH=c:\matlab_sv13\bin\win32 arguments = /r test /logfile log.txt log = mat.log Output = mat.out Error = mat.err Queue 1 

 This method of running matlab with condor is posted on the
web and it is tested to work by other users. I believe it has something to do with the fact that the matlab engine tries to open a window, and that might not be allowed by the condor runtime system.

 I have checked the "execute" dir on the execute machine. The files are staged nicely and the local process 
is started. The StarterLog says

7/14 16:01:06 About to exec C:\WINDOWS\System32\cmd.exe /Q /C condor_exec.bat /r x /logfile log.txt 7/14 16:01:06 Create_Process succeeded, pid=2160

 If I run the EXACT command line from a command prompt inside the execute directory on the execute machine, I can sucessfully run the application, with the same environment  settings.

 My guess is that the proplem occurs when the process tries to popup the matlab window. I have tried to use the switches /nosplash /nodesktop and /minimize, but no effect.

 I have even tried with a basic .m file containing only the exit command, but no success.

 Any ideas?

 Thanks and regards

Vreau sa-mi inregistrez CV-ul la BursaMuncii!
Vreti sa publicati oferte de munca? Noi avem solutia!
Lasa profesionistii sa lucreze pentru tine! http://www.bursamuncii.ro

Condor-users mailing list
Condor-users@xxxxxxxxxxx http://lists.cs.wisc.edu/mailman/listinfo/condor-users