[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Condor-users] a vanilla job

> Hi ,
> I am using the following submission file for condor:
> executable=/bin/sh
> arguments=-c date +%s
> output=res.out
> error=res.err
> log=res.log
> universe=vanilla
> notification=never
> queue
> and I 'd expect a result like
> 1088427848
> but I obtain :
> Mon Jun 28 14:58:00 CEST 2004
> In effect condor jobs seem to parse only the 1st argument: It really 
> execute a  process  
> /bin/sh -c date  --->  Mon Jun 28 14:58:00 CEST 2004
> and not
> /bin/sh -c date  +%s --->  1088427848

If I run this on the command line, I get the same result as your Condor is
giving (Whitebox

If I run it on cygwin, it gets confused with the % (presumably windows

Putting single quotes around the date part seems to work on the command

/bin/sh -c 'date +%s'

Maybe sh is gobbling the +%s, thinking it is one of its options.
BTW I think double quotes would also do the trick.

Does this work?