[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] Java Universe Red Hat 8 configuration problem

David Kotz wrote:

I have the same problem running under Debian Woody.  We've never been
able to get the Java universe working.

condor_starter -classadd   correctly shows Java, but it seems that the
daemons don't see it when they start.

- dave

On Tue, 2004-06-29 at 19:12, bfargo@xxxxxxxxxxxxxx wrote:

I am having problems configuring and getting condor to run jobs inside the java universe. In my condor cluster I have two machines both with RH8 running on an intel x86 architecture. I looked through the condor FAQ's and manual sections on classads and java to try and discover a solution to my problem but found nothing.

The job that I am submitting is a simple hello world program and I am submitting it with the example ClassAd that I found in the Java section of the Condor Manual. I run condor_q -analyze to see what the problem is and get the following output.
[condor@master condor]$ ./bin/condor_q -analyze

-- Submitter: master.condor : <> : master.condor ID OWNER SUBMITTED RUN_TIME ST PRI SIZE CMD --- 013.000: Run analysis summary. Of 2 machines, 2 are rejected by your job's requirements 0 reject your job because of their own requirements 0 match, but are serving users with a better priority in the pool 0 match, but prefer another specific job despite its worse user-priority 0 match, but will not currently preempt their existing job 0 are available to run your job No successful match recorded. Last failed match: Tue Jun 29 13:15:40 2004 Reason for last match failure: no match found

WARNING:  Be advised:
  No resources matched request's constraints
  Check the Requirements expression below:

Requirements = (HasJava) && (Disk >= DiskUsage) && ((Memory * 1024) >= ImageSize) && (HasFileTransfer)

I thought from this perhaps HasJava is evaluating to false so I tried

[condor@master condor]$ ./bin/condor_status -java

I get no output from this command. However when I run the other command that was in the condor manual I receive confusing output:

[condor@master condor]$ ./sbin/condor_starter -classadd
CondorVersion = "$CondorVersion: 6.6.5 May  3 2004 $"
IsDaemonCore = True
HasFileTransfer = True
HasMPI = True
HasJICLocalConfig = True
HasJICLocalStdin = True
JavaVendor = "Sun Microsystems Inc."
JavaVersion = "1.4.2_04"
JavaMFlops = 142.830582
HasJava = True

This indicates that HasJava as well as HasFileTransfer are evaluating to true. I am not running an ancient computer with a small amount of diskspace or Memory so the Requirements error I am getting is confusing me. Does anybody have any suggestions on what I could try or change to get my Java universe properly running or can somebody point me in the direction of a resource that can get me on my way to solving this problem. Your help will be apprectiated. Thank you.

William Fargo
Referentia Systems Incorporated

Condor-users mailing list


I have had a problem with java not showing up and found out that a line had to be commented out in the condor_config file, the following is the line:


Ran into this problem with execution machines running with Xeon/P4 processors. Hopefully this helps you out.

Dustin M Binge
Research Computing Core
University of South Florida
Office: LIB 613
Phone: 813-974-1467