[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] Condor problems

On Mon, 14 Feb 2005, Darryl Cook wrote:

> Actually I see in the condor_q that the job completes but I get no
> output from the /bin/ls command.   I dont see any errors though to give
> me a clue as to why.   I did find an article though on the condor site
> that says shell scripts wont run unless  the Condor administrator has
> opted to do a full install of condor_compile.   Begin that Condor
> Administrator :-)   I dont really know whether that is the case or not.
> I do know that if I say condor_compile /bin/sh <shell script> that  I
> get a usage statement back saying to use gcc, cc etc etc..so I am
> thinking maybe that is why it isnt giving me any output back on the
> /bin/ls executable.

Are you also capturing the error for the job? Is it empty as well?

> I ran the fib example a little differently putting in the universe and
> globuscheduler commands.  What if I run it with the following which did
> run successfully:
> Executable = fibonacci
> globusscheduler = node1.cs.appstate.edu/jobmanager-fork
> universe=globus
> Output = fib.out
> Log = foo.log
> Queue 1
> would this imply that condor-g ran successfully  or if not how do I test
> it ??

Did fib.out contain the output you expected?

|            Jaime Frey            |  Public Split on Whether        |
|        jfrey@xxxxxxxxxxx         |  Bush Is a Divider              |
|  http://www.cs.wisc.edu/~jfrey/  |         -- CNN Scrolling Banner |