[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Condor-users] Can't Get Condor To Work At All on Windows - Problems I Noticed

I figured I would take a stab at installing and using Condor.  I tried to install both 6.7.8 and 6.6.10 and had no luck with either.

The machines I tried to install this on are:

  Windows 2003 sp1 Domain Controller (made it central manager)


  WindowsXP sp2 (joined to existing pool)


I first tried to install 6.7.8.  I realize it is a development release, but it seemed more feature complete.  During installation I received 2 dialog box errors.  Both had the title “Grepping” and the message was “Couldn’t find [COLLECTOR_NAME] in [condor_config.local]” and “Couldn’t find [DAEMON_LIST] in [condor_config.local]”.  Installation continued normally after these 2 errors.  I included my subnet to have read and write permission and used my FQDN for the admin field.

After install, I started the Condor service.  The install docs said several services should start, depending on the rolls of the particular machine.  Only the condor_master.exe was running.  Restarting the Condor service would not start the collector process or any other process.  Since I received errors about condor_config.local, I attempted to look at the file with notepad.  The file seems to not be formatted properly.  I needed to use wordwrap to see all of the contents and there were some symbols on every line (mixed with the actual words).  I think it is a unix vs dos format problem.  I also noticed in the condor_config file that the paths for every variable are using the wrong slash for the path and actually mixing slashes.  Instead of c:\condor\bin, I see c:\condor/bin.


Installing on the WindowsXP went more smoothly.  I installed this as a node on an existing pool.  No errors popped up; however, I had the same problem with only the condor_master.exe running.


I eventually gave up on the devolopment version and tried the stable release (6.6.10).  It installed fine on both computers; however, I had the same goofy path problem in my condor_config file but condor_config.local looked fine.  Still, only the condor_master.exe service was running and the other processes, such as condor_collector would not start.



I’m going to try installing this on a Gentoo Linux box that I have and make it the central manager.  Hopefully I will have better luck on Linux.



John Alberts
Technical Assistant for EMS
Purdue University Calumet