[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Condor-users] condor_config_val doesn't set/retreive custom values properly

Hi all,

I'm trying to set a runtime property on some condor nodes. I used 
condor_config_val on my local node, and after solving a config problem 
(security level was not set) here is what I obtain:

$ condor_config_val -set "JCAE_READY = true"
Successfully set configuration "JCAE_READY = true" on master 
patrouille.grideads.net <>.
$ condor_config_val JCAE_READY
Not defined: JCAE_READY

Looking at the MasterLog doesn't help me so much:

7/13 11:16:26 DaemonCore: Command received via TCP from host 
7/13 11:16:26 DaemonCore: received command 60002 (DC_CONFIG_PERSIST), 
calling handler (handle_config())

I also tried with different syntaxes, as I didn't know exactly the 
difference between a macro and an expression in that case (I tried 
JCAE_READY=true, "JCAE_READY : true", JCAE_READY:true, I tried with 
rset, and I tried addressing directly to the schedd, each of these 
solutions giving the same "Successfully set configuration" message and 
"Not Defined" afterward).

Am I doing something wrong ? Is this a problem with my configuration ?


Matthieu Cargnelli