[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Condor-users] condor_master error

> I recently tried to move the location of LOCAL_DIR from an nfs drive
> a directory on a local disk (but not the root disk).  I am able to run
> condor_configure to move the log, execute, and spool directories to
> new location (although I am curious as to why these directories are
> created with owner condor and group root?), but when I then try to run
> condor_master, which I start up as root, I get the following error:
> Can't open "/viewstore/condor/log/MasterLog"
> 6/7 13:42:08 dprintf() had a fatal error in pid 31177
> Can't open "/viewstore/condor/log/MasterLog"
> errno: 13 (Permission denied)
> euid: 50025, ruid: 0
> 50025 is the uid of condor (CONDOR_IDS is set to the condor uid.gid).
> get the same error if I change the group of the LOCAL_DIR directories
> condor.  However, I can su condor and explicitly create
> /viewstore/condor/log/MasterLog.
> Any idea what's going on?

I'm not exactly sure what's going on with condor_configure, but I do
know that it has been known to cause problems.  Assuming that it's ok to
blow the new contents of LOCAL_DIR away, I'd go to /viewstore/condor and
'rm -rf log spool execute', then (as user condor) 'mkdir log spool
execute'.  Then try starting the master as root.

BTW, you don't need to set CONDOR_IDS at all if you have a condor
account.  I don't think that's related to your problem, though.

Mike Yoder
Principal Member of Technical Staff
Direct : +1.408.321.9000
Fax    : +1.408.904.5992
Mobile : +1.408.497.7597

Optena Corporation
2860 Zanker Road, Suite 201
San Jose, CA 95134