[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] error 1067 (the most obvious newbie user problem :))

I got this both from an win2k machine at home, and a winxp at the office :(

I also got an answer from Michael from Optena, and he writes the following:

On 9/29/05, Michael Yoder <yoderm@xxxxxxxxxx> wrote:
> 9/29 01:21:23 bind failed: WSAError = 10038

10038 is "'WSAENOTSOCK' -- Socket operation on non-socket."

Based on what I see in this article:

I think you may need to set your computer up with a static IP address.

But both my home and office computer have a static IP address. So I still got nowhere and it's very annoying. :(

On the Optena site there is a mention of Condor sensitive to getting the full domain name of
a computer. I don't know what this means if I have just a local network of computers. There's
no domain in that case AFAIK (and I wouldn't like to have one set up just because of this, to
be honest :)). The thing is, I don't know how should I set up settings like FULL_HOSTNAME
in that case. Any ideas would be appreciated...



On 9/29/05, Matt Hope <matthew.hope@xxxxxxxxx> wrote:
On 9/29/05, Imre Tuske <imre.tuske@xxxxxxxxx> wrote:
> Hi,
> Sorry for bothering you with this one, but I'm desperate, and I yet found
> only unanswered questions of exactly the same
> issue on this list.
> I'm trying to start condor_master on a (supposed) master machine with all
> the same success. :( I'm getting the following:
> 9/29 01:21:23
> ******************************************************
> 9/29 01:21:23 ** condor_master (CONDOR_MASTER) STARTING UP
> 9/29 01:21:23 ** C:\Condor\bin\condor_master.exe
> 9/29 01:21:23 ** $CondorVersion: 6.6.10 Jun 22 2005 $
> 9/29 01:21:23 ** $CondorPlatform: INTEL-WINNT50 $
> 9/29 01:21:23 ** PID = 1636
> 9/29 01:21:23
> ******************************************************
> 9/29 01:21:23 Using config file: C:\Condor\condor_config
> 9/29 01:21:23 Using local config files: C:\Condor/condor_config.local
> 9/29 01:21:23 bind failed: WSAError = 10038
> 9/29 01:21:23 Failed to bind to command ReliSock9/29 01:21:23 (Your system
> network settings might be invalid.)9/29 01:21:23 ERROR "BindAnyCommandPort
> failed" at line 6009 in file
> ..\src\condor_daemon_core.V6\daemon_core.C
> I also tried to specify my computer's ip address using NETWORK_INTERFACE,
> but it didn't help. (It's a Win2K (workstation) OS.)
> I read on the Optena site (there's a nice Condor section) that Condor is
> sensitive to DNS issues (ip address <-> hostname translation), and they
> suggest either to have a DNS server or a properly set up hosts file (which I
> have). Unfortunately I'm not a network expert, so I don't know how would I
> get "full domain names" for machines in a local network.

We got exactly the same issue on some newly built PC's (XP not 2K).

Turns out that removing PGP from them fixed it - I'm guessing
something else might be using the command port it is trying to use?