[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Condor-users] Starting condor_master on boot

Hi All

I am having a problem getting condor_master to start on Novell OES Linux (based
on SLES).  I have added the supplied condor.boot file to my init.d directory,
pointed the file at the right condor_master location,  and run chkconfig to add
the service to the list, however none of this has worked.  

1) When I reboot the machine and login remotely using SSH, "ps -ef | grep
condor" returns nothing.

2) When I start the service manually using "/etc/init.d/condor start", "ps -ef
| grep condor" returns something i.e. condor is working.

3) During bootup I get the following message...

Neither the environment variable CONDOR_CONFIG,
/etc/condor/, nor ~condor/ contain a condor_config file.
Either set CONDOR_CONFIG to point to a valid config file,
or put a "condor_config" file in /etc/condor or ~condor/

The thing that puzzles me is that I _have_ defined CONDOR_CONFIG...

I have a file, /etc/profile.d/condor.sh, that is called whenever a shell opens
that exports the following variables

export CONDOR_CONFIG=/opt/condor-6.6.11/etc/condor_config
export MANPATH=$MANPATH:/opt/condor-6.6.11/man

Those exports are picked up and used successfully when I run the service
manually from the shell.  

Is it possible that these environment variables are not set before the
/etc/init.d/condor file is called ?

If so, does anybody have any suggestions on how to proceed ?

I have tried adding CONDOR_CONFIG as above to "/etc/init.d/condor" - no luck

Is this problem one that many have after installing using condor_configure ?

Is the problem the condor_master, if so can it be told where to look for the
condor_config file ?

Does everybody just put their condor_config files in /etc/condor and everything
just works - tried that - no luck

BTW the machine is configured using DHCP and the hostname is changed from
"linux" to "somethingelse" during booting which causes further config errors,
i.e. it appears to pass the "Neither the environment variable CONDOR_CONFIG"
error but then starts to complain about not being about not being able to find
the linux.local directory instead of somethingelse.local

Is there a way to make sure that condor is started up last by changing the
chkconfig line at the top of "/etc/init.d/condor" ?

Or should I just go through and rewrite the condor_config file and dump it in
/etc/condor ?

Maybe this e-mail could start a list of gotchas re installing condor on suse

Any suggestions ?

Thanks in advance



Dr James Osborne, BSc (hons), PhD
High End Computing Support Engineer
Information Services, Cardiff University, 50 Park Place, Cardiff CF10 3AT,
Wales UK
Tel: +44(0)29 2087 4657
Fax: +44(0)29 2087 4285
Email: osborneja1@xxxxxxxxxxxxx 
Web: http://www.cardiff.ac.uk/insrv/condor