[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] Initial installation - I don't understand whythejob cannot write its own file?

Sure, it can't hurt much. I suspect that the different domain names on
master/client and the mechanism for user authentication is the problem,
if you don't have this sort of thing on your 2 machines it might not
have the same problem. 

Further info: I tried setting  SOFT_UID_DOMAIN = TRUE but still the same
behaviour. The cluster user authentication is as described in the entry
for this keyword, the users are not stored in /etc/password 

HOST_ALLOW_READ = * , ie I have tried (for testing!) to open up all
security but still experience the same behaviour.

What condition is causing the job to execute as NOBODY instead of the
submitting user? I think that is what I need to understand.

Thanks again


-----Original Message-----
From: condor-users-bounces@xxxxxxxxxxx
[mailto:condor-users-bounces@xxxxxxxxxxx] On Behalf Of bruce
Sent: 31 July 2006 20:26
To: 'Condor-Users Mail List'
Subject: Re: [Condor-users] Initial installation - I don't understand
whythejob cannot write its own file?

hi robert.

i'm no guru! but i've just recently got a 2 node master/client condor
setup to more or less work. i can submit a job, which queues up copies
of a perl script that then appear to get run on the two machines..

i can send you the condor_config/local config files that i have if you
think it might help..


-----Original Message-----
From: condor-users-bounces@xxxxxxxxxxx
[mailto:condor-users-bounces@xxxxxxxxxxx]On Behalf Of Atwood, Robert C
Sent: Monday, July 31, 2006 12:18 PM
To: Condor-Users Mail List
Subject: [Condor-users] Initial installation - I don't understand why
thejob cannot write its own file?

I have installed Condor on a small cluster on its own private network.
The master has 2 interfaces (outside network , cluster network). I've
got it configured so that jobs can be submitted and they run on the
nodes, with minimal chages to the default configuration. 

However, there is a peculiar problem that I cannot figure out.

When the (vanilla) job starts, the output file is created, belongong to
the submitting user, with permissions -rw-r--r--  Then the job gets
held, with the log message: 

 "Error from starter on vm2@xxxxxxx : Failed to open
'/home/myuser/q/loop.out' as standard output: Permission denied (errno

The job runs as  'nobody',  but the file is created with ownership of
the submitting user. This doesn't seem right. 

I tried altering the UID_DOMAIN to all different things that I could
think of (domain of the master's outside, domain of the private network,
* ) with no difference in this behaviour. 

I thought this file should be created in /local/condor/execute , where
/local/condor is defined in the configuration file by LOCAL_DIR, not in
the submitting working directory, anyways? That is what I would like, I
thought that was the default for vanilla jobs? 

Any suggestions appreciated,


#include <stdio.h>
#include <unistd.h>
int main (){
  int i;


# Submit description file for loop program
Executable     = loopit
Universe       = vanilla
Output         = loop.out
Log            = loop.log
TARGET.FileSystemDomain = *

Condor-users mailing list
To unsubscribe, send a message to condor-users-request@xxxxxxxxxxx with
subject: Unsubscribe
You can also unsubscribe by visiting

The archives can be found at either