[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Condor-users] createCluster() failed in SOAP on 6.7.20

I'm trying to follow Matt's slides from Condor Week on setting up SOAP.  I'm getting an error saying "Could not create new cluster" whenever I run the following code.  Anyone have any ideas why this might be?


Thanks in advance for any help!






My Java code:


        Schedd schedd = new Schedd(new URL("http://xxx.xxx.xxx.xxx:xxxxx"));


        Transaction t = schedd.createTransaction();



        int cluster = t.createCluster();   // This line produces the error

        int job = t.createJob(cluster);

        File[] files = {new File("cp.sub")};


        t.submit(cluster, job, "root", UniverseType.VANILLA, "/bin/cp", "cp.sub cp.worked", "", null, files);





Excerpt from condor_config:






# I don't know what the next line is for, but I saw it in some examples.

# I get the same error if it's commented out.



ALLOW_SOAP = *.fairisaac.com




Excerpt from SchedLog:



6/22 17:42:58 (pid:23536) Received HTTP POST connection from <xxx>

6/22 17:42:58 (pid:23536) Current Socket bufsize=85k

6/22 17:42:58 (pid:23536) Current Socket bufsize=16k

6/22 17:42:58 (pid:23536) About to serve HTTP request...

6/22 17:42:58 (pid:23536) SOAP entered newCluster(), transaction: 2604208385

6/22 17:42:58 (pid:23536) QMGT command failed: anonymous user not permitted

6/22 17:42:58 (pid:23536) NewCluser(): OwnerCheck failed

6/22 17:42:58 (pid:23536) SOAP leaving newCluster() result=1

6/22 17:42:58 (pid:23536) Completed servicing HTTP request

6/22 17:43:28 (pid:23536) SOAP in transtimeout()

6/22 17:43:28 (pid:23536) SOAP entered abortTransaction(), transaction: 2604208385


This email and any files transmitted with it are confidential, proprietary
and intended solely for the individual or entity to whom they are addressed.
If you have received this email in error please delete it immediately.