[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Condor-users] nicl/useradd for condor 6.8.4 under Mac OS X

Dear Users,

I'm looking to create the condor under under Mac OS X and use it with non-shared home. I've already tried it with useradd and nicl but it jobs just sit in the queue while MatchLog shows up not match even though condor_status looks fine:

$ condor_status

Name OpSys Arch State Activity LoadAv Mem ActvtyTime

vm1@xxxxxxxxx OSX PPC Unclaimed Idle 0.000 512 0+00:20:15 vm2@xxxxxxxxx OSX PPC Unclaimed Idle 0.000 512 0+00:20:16

Total Owner Claimed Unclaimed Matched Preempting Backfill

PPC/OSX 2 0 0 2 0 0 0

Total 2 0 0 2 0 0 0

I tried setting the following:

nicl / create /users/condor
nicl / create /users/condor gid 502
nicl / create /users/condor uid 502
nicl / create /users/condor home /home/condor
nicl / create /users/condor shell /bin/bash
nicl / create /groups/condor
nicl / create /groups/condor gid 502

Then I just install the condor-6.8.4 tarball for Mac OS X 10.3 and set its CONDOR_HOST to be a Linux machine. I presume this is allowable?

I set up 3 linux nodes of type CentOS 4.4, SL3 and SuSE 9.3 and each of these seems to function correctly so the Mac OS X version you would expect to behave similarly.

I set tried submitting the /bin/hostname and a simple bash script to see if they would be submitted to the cluster. They doesn't.

I notice that I'm getting from the StartLog on the execute node contains:

vm1: State change: IS_OWNER is false

I'd presume this should have changed to IS_OWNER is true.
Any help would be appreciated on this.

With Best regards,
Eamonn Kenny