[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] weird behavior -- commas and quotes condor_submitarguments

I have tried various incantations (including on 6.9.3) and can't find
out how to pass the commas through, they seem to separate the input into 
2 args. I assume that is a bug.

There are several strange things going on their with the backslashes and the
extra quotes surrounding the args (they should have been stripped).

Note that

('''arg1''','''arg2''') is actualy parsed as 
( ' '' arg1 '' , '' arg2 '' ' )
(''''arg1'''',''''arg1'''') surprisingly gives the same output


-----Original Message-----
From: condor-users-bounces@xxxxxxxxxxx on behalf of mavademe@xxxxxxxxx
Sent: Sat 11/08/2007 19:58
To: condor-users@xxxxxxxxxxx
Subject: [Condor-users] weird behavior -- commas and quotes condor_submitarguments
Help! I'd like to run a condor job with arguments that contain double
quotes, single quotes, and commas, but condor_submit is always able to
mangle my input beyond recognition. As a testbed, I run a batch file that
just echo's its input arguments, like so:

echo %1 %2 %3 %4 %5 %6 %7 %8 %9

When I then submit the following:

executable = echo_inputs.bat
universe = vanilla
arguments = """myfunction('''arg1''','''arg2''')"""

I'm using the new style arguments formatting: the intention is to end up
with "myfunction('arg1','arg2')". HOWEVER, what actually gets run (the
output of the echo batch file) is

"\"myfunction('arg1' 'arg2')\""

(Note dissapearance of comma, backslash insertion, and lack of double double
quote deletion.) As I understand it, this is not at all in agreement with
the condor_submit documentation at

Can someone shed light on this? I'm using 6.8.5 with all Windows machines.


- Matthijs