[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] "ExeCaKeyF04" error


I was getting this problem a lot recently trying to install Condor as the supplied MSI, through Active Directory. It kept coming up with this same error. I thought that there was a problem with the downloaded MSI file that I had obtained. I uninstalled condor through the usual "Add/Remove programs", then rebooted the machines, manually removed the c:\condor directory and then used RegEdit to remove the HKLM/software/condor (or whatever it's path was) from the registry. I downloaded a fresh version of the MSI, and reapplied the new MSI to the machines through AD. It's worked without a problem on the PCs since. I know that it might be a silly question, but have you checked the Event Viewer log to see if there were any other errors on the PCs before the Condor install - just in case it got caught up with something before hand? I've had the Windows Installer mess up before, which has caused all sorts of issues in other software installs at a later point?

If you do find out the cause for the problem, can you let the mailing list know, as it sounds like a bit of a bugbear!?

Mark Russell

--On 19 May 2007 11:23 +0000 simon kagwe <simonkagwe@xxxxxxxxx> wrote:

I have asked this question before but still I can get a correct solution.
I am  trying to install Condor 6.8.4 on an XP machine using the MSI and
towards the  end I get the following error:

CUSTOM ACTION "ExeCaKeyF04" FAILED (unexpected return code). LOCATION:
C:\Condor\, COMMAND: "cmd.exe" /c condor_set_acls.exe ?C:\Condor?

I thought it was a bug in 6.8.4 and so yesterday I tried 6.8.5 and I'm
still  getting the error. I'm now going to try an earlier version, since
according to  earlier posts they don't exhibit the same phenomenon. But I
think the Condor  developers might want to look into this. It has
happened to other people  before.

If you have a solution, please share.

Condor-users mailing list
To unsubscribe, send a message to condor-users-request@xxxxxxxxxxx with a
subject: Unsubscribe
You can also unsubscribe by visiting

The archives can be found at:

E-Learning and IT Support Officer
Faculty of Science
ext 3753
1.22 1 South
University of Bath