[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] problem running condor_master "can't open MasterLog"

Many thanks!!
The problem is done.
I created a 'condor' user on the Redhat, and setted the condor_IDS in the local configure file. Then ran condor_init, and condor_master worked.
Thanks again!
2007/10/29, Steven Timm <timm@xxxxxxxx>:
On Mon, 29 Oct 2007, Shiyang Zhao wrote:

> Hi all,
> I installed Condor 6.8.6 on Linux Red Hat 9.0.
> I tried to run condor_master  as Root, but failed.  The message is

condor_master starts as root but then it will
switch uid to whatever uid and gid is set by CONDOR_ID's
in the configuration file.
The log directory needs to be owned by the right user.
If you run condor_init first, it will make the log
and spool and execute directories under /condor/local.my_linux
and change them to the right ownership.


> ****************************************************************
>        Can't open /condor/local.my_linux/log/MasterLog.
>        dprintf() had a fatal error in pid xxxxx.
>        Can't open /condor/local.my_linux/log/MasterLog.
>        errno: 13 (Permission denied).
>        euid: x, ruid x
> ****************************************************************
> I couldn't find the file named MasterLog in the "log" directory, the
> directory is empty. I created a new file named this as Root, but it did not
> work.
> I searched our previous topics, and found that some one also encountered the
> same problem. But did not find a definite answer to my problem.
> Looking forward to your advice.

Steven C. Timm, Ph.D  (630) 840-8525
timm@xxxxxxxx  http://home.fnal.gov/~timm/
Fermilab Computing Division, Scientific Computing Facilities,
Grid Facilities Department, FermiGrid Services Group, Assistant Group Leader.
Condor-users mailing list
To unsubscribe, send a message to condor-users-request@xxxxxxxxxxx with a
subject: Unsubscribe
You can also unsubscribe by visiting

The archives can be found at:

Sincerely yours,
Zhao Shiyang