[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Condor-users] pgf90 in standard universe

I have a program that runs fine in the vanilla universe.  When I try
using the standard universe the program crashes immediately because
the first input file it reads from has been overwritten with zero
bytes.  I tried changing the code to make the FORTRAN open statement
explicitly read-only, but then I get "permission denied errors".  In
other words, the program really wants to overwrite this file when it
runs in the standard universe.   A simple FORTRAN 90 test program I
wrote did not experience this problem when compiled with gfortran, but
unfortunately the program I need to run uses some Portland specific
language features so I really have to use pgf90.  I am using Condor
version 7.0.5.  I have tried pgf90 versions 6.1 and 7.1, both with the
same result.

Dan Bretherton

Mr. D.A. Bretherton
Reading e-Science Centre
Environmental Systems Science Centre
Harry Pitt Building
3 Earley Gate
University of Reading
Reading, RG6 6AL

Tel. +44 118 378 7722
Fax: +44 118 378 6413