[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] GAHP and proxy

condor-users-bounces@xxxxxxxxxxx schrieb am 05/15/2008 01:09:29 AM:

> Dear Condor Team: 
>      I am experiencing a problem with Condor-G submission. Below is 
> a segment copied from GrimanagerLog that explained the issue. My 
> question is that where exactly does GAHP server copy the proxy 
> certificate from?

>From the usual location (/tmp/x509up_uXXXX), but you can tell it to pick 
it up from elsewhere (see in the manual). The copying is done not 
by the GAHP server, but by the condor_gridmanager process. You can strace 
it to find out what it is doing with files.

> I have tried generating new proxy and restarting 
> Condor before resubmitting another job but nothing worked. Also, 
> globus-job-run command was successful so I really don't see why 
> proxy is problematic. It's been forever that I keep getting stuck 
> with INITIALIZE_FROM_FILE failure ...  :( 
> 5/14 18:23:10 [7388] GAHP[7414] <- 'INITIALIZE_FROM_FILE 
> /tmp/condor_g_scratch.0x85c5e48.23467/master_proxy.2'
> 5/14 18:23:10 [7388] GAHP[7414] -> 'F' '7' 'Failed to activate 
> Globus' 'modules'
> 5/14 18:23:10 [7388] GAHP command 'INITIALIZE_FROM_FILE' failed: 7
> 5/14 18:23:10 [7388] GAHP: Failed to initialize from file
> 5/14 18:23:10 [7388] (11.0) Error initializing GAHP

Did you check that the file reported in the GridmanagerLog: 
/tmp/condor_g_scratch.0x85c5e48.23467/master_proxy.2 is readable to the 
user running the GAHP java process and contains the same content as 

This Globus bug report (allegedly fixed) indicates that access rights to 
other directories may be causing problems, too:


Maybe you should also strace the GAHP process to see whether it is getting 
EACCES somewhere.

Jan Ploski