[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Condor-users] Application runs in standalone mode but not via condor

Hi all,
 This is a weird problem I have been trying to crack .. like forever. Still no clue. I have an application that I compiled with c++ 4.1.2. This application uses STL heavily and I had trouble compiling this application with c++ version 3.x. But 4.1.2 compiles and generated a condor checkpointable executable just fine. The problem is: If I run the executable in standalone mode, the executable runs perfectly. I can send checkpoint signals using kill -TSTP, kill -USR2 etc... and the executable generated checkpoint and resumes or exits -- as it should. But, when I submit the same executable to condor via condor script and all, the executable does not run. This application has a weird requirement that the HOME environment variable cannot be a null string. It can be anything, so even if I set the HOME env variable to /tmp, the executable runs okay in the standalone mode. This is exactly what I do from within the condor wrapper script that wraps around this executable. I set the HOME env var and then execute the application. But, still with no luck.

Can some one shed some light on what might be going wrong here?  Any insight or sharing of similar experiences will be appreciated.