[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] CREDD - Can't find address for credd host5.domain

On Monday 11 April 2011 19:14:28 kschwarz@xxxxxxxxxxxxxx wrote:
> Michael , Tamesgen, and users community,
> I thought the problem was solved, but it was not.
> Doing more tests I noticed that the problem had nothing to do with
> configuration of DNS suffixes. It was a coincidence it worked the other
> time.
> To solve the problem, CREDD_HOST should be set to the fully qualified
> hostname of the CREDD machine (appending the domain suffix).
> And to share the same secret on all machines, UID_DOMAIN parameter must be
> set to the domain to be used,  for all machines in the pool. This is not
> in the condor_config.local.credd example file that comes with the Windows
> distribution package.
> Could the Condor Development make an update of the
> condor_config.local.credd to include the need of the UID_DOMAIN
> parameter?!!

I had an issue in the past with condor credd and ad matching: the comparison 
is done in a case sensitive way, which can be a problem if you spelled the 
CREDD_HOST variable in different ways in the various configuration files of 
the different machines. 

Alexandre Fayolle                              LOGILAB, Paris (France)
Formations Python, CubicWeb, Debian :  http://www.logilab.fr/formations
Développement logiciel sur mesure :      http://www.logilab.fr/services
Informatique scientifique:               http://www.logilab.fr/science