[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] Condor + EC2

Hi Matthew,

I saw your blog, i just did not had the time to test your steps. I am downloading the debian package and will try that using ubuntu.
If I dont get it running and I have to go for fedora then...

Is it really necessary to use condor_shared_port? I saw here ( http://www.isi.edu/~gideon/condor-ec2/ ) that you can just specify a port range.
Anyway you gave me an idea, would it be possible to use condor_shared_port and tunnel all the communication trough ssh? how difficult would that be?

Thanks for your help

On Tue, Nov 15, 2011 at 3:36 AM, Matthew Farrellee <matt@xxxxxxxxxx> wrote:
On 11/15/2011 01:27 AM, Tiago Macarios wrote:
Hi all,

I am trying to get condor to run on amazon ec2. I am trying to use
ubuntu and the standard apt-get ubuntu (7.2.4), but I saw at some places
that this version may be a bit old for that. Did any of you guys made it
work using this configuration?

Would you have any suggestion of distros I could try? I found this link
that seems to be what I wanted to do, but I am not familiar with Fedora
and wanted to try ubuntu first:

To be honest I am new to condor, have been playing around for about 2
weeks on a couple of virtual machines. I tried installing the last
stable release of condor in ubuntu, but I failed is there a tutorial for
installing it on ubuntu?
I saw this version here: http://neuro.debian.net/pkgs/condor.html did
anyone tried it out?

Please help me out. I am more than willing to write a documentation
about it if I get things running.


If you want to run your whole pool in EC2 then you should try following,




The primary difference for the instructions in EC2 is that you need to authorize ports in the instance's security group as well as iptables.

The instructions talk about using the condor_shared_port feature, which isn't available in 7.2.4 (IIRC).

If you're itching for Ubuntu, you could try UW's debian repository from,


Otherwise, I'd suggest just trying the Fedora AMIs,


A gotcha[0] is resolved in the updates-testing repository.



[0] https://bugzilla.redhat.com/show_bug.cgi?id=656562