[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Condor-users] Condor 7.7.5 not obeying local configuration?

I'm not sure whether this is a feature, a misunderstanding on my side, or
a Condor bug...

When freshly installing cluster nodes, I don't want Condor to start on 
reboot - I'm still trying to fix some other setup issues, and users
shouldn't claim a machine that will probably go down again.

Since I have both LOCAL_CONFIG_FILE and LOCAL_CONFIG_DIR set, I tried
to use a file in /etc/condor/condor_config.d containing "START=False":

root@o201:/etc/condor/condor_config.d# cat zzzlocal
START = False

Consequently, when the node has started,

root@o201:/etc/condor/condor_config.d# condor_config_val START

Checking the config settings again:

root@o201:/etc/condor/condor_config.d# condor_config_val -dump | grep LOCAL_CONFIG
LOCAL_CONFIG_DIR = $(ETC)/condor_config.d
LOCAL_CONFIG_DIR_EXCLUDE_REGEXP = ^((\..*)|(.*~)|(#.*)|(.*\.dpkg-.*)|\.off)$
LOCAL_CONFIG_FILE = $(ETC)/condor_config.$(OPSYS).$(ARCH), $(TILDE)/etc/$(HOSTNAME).local, $(TILDE)/etc/$(HOSTNAME).local.forced

but there is an active STARTD process:

root@o201:/etc/condor/condor_config.d# ps auxw | grep condor
condor    1901  0.0  0.2  91920  6016 ?        Ss   Mar27   0:10 /usr/sbin/condor_master -pidfile /var/run/condor/condor.pid
condor    1924  0.0  0.3  90940  7008 ?        Ss   Mar27   0:00 condor_startd -f
root      4017  0.0  0.0   7548   848 pts/0    S+   09:00   0:00 grep condor

Previously, I used ~condor/etc/* files (TILDE=/home/condor) - which worked -
but since the init script doesn't depend on $remote_fs I had to change this.

Can someone help me see what's causing the problem?


Steffen Grunewald * MPI Grav.Phys.(AEI) * Am Mühlenberg 1, D-14476 Potsdam
Cluster Admin * --------------------------------- * http://www.aei.mpg.de/
* e-mail: steffen.grunewald(*)aei.mpg.de * +49-331-567-{fon:7274,fax:7298}