[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] Condor 7.7.5 not obeying local configuration?

Hi Steffen,

The START parameter in local configuration does not control daemon startup, it only affects startd behavior. Setting it to false means the startd will never start any job (there should be no condor_exec processes). If you want to prevent the startd daemon from running at all, but you still want the master up, you could set DAEMON_LIST = MASTER in local configuration. If you want to stop all condor daemons from running, it is simpler to use whatever flavor of init your system has. At least on Debian, there is no startup switch in /etc/default/condor either.



Steffen Grunewald <Steffen.Grunewald@xxxxxxxxxx> wrote:

>I'm not sure whether this is a feature, a misunderstanding on my side,
>a Condor bug...
>When freshly installing cluster nodes, I don't want Condor to start on 
>reboot - I'm still trying to fix some other setup issues, and users
>shouldn't claim a machine that will probably go down again.
>Since I have both LOCAL_CONFIG_FILE and LOCAL_CONFIG_DIR set, I tried
>to use a file in /etc/condor/condor_config.d containing "START=False":
>root@o201:/etc/condor/condor_config.d# cat zzzlocal
>START = False
>Consequently, when the node has started,
>root@o201:/etc/condor/condor_config.d# condor_config_val START
>Checking the config settings again:
>root@o201:/etc/condor/condor_config.d# condor_config_val -dump | grep
>LOCAL_CONFIG_DIR = $(ETC)/condor_config.d
>LOCAL_CONFIG_FILE = $(ETC)/condor_config.$(OPSYS).$(ARCH),
>$(TILDE)/etc/$(HOSTNAME).local, $(TILDE)/etc/$(HOSTNAME).local.forced
>but there is an active STARTD process:
>root@o201:/etc/condor/condor_config.d# ps auxw | grep condor
>condor    1901  0.0  0.2  91920  6016 ?        Ss   Mar27   0:10
>/usr/sbin/condor_master -pidfile /var/run/condor/condor.pid
>condor    1924  0.0  0.3  90940  7008 ?        Ss   Mar27   0:00
>condor_startd -f
>root      4017  0.0  0.0   7548   848 pts/0    S+   09:00   0:00 grep
>Previously, I used ~condor/etc/* files (TILDE=/home/condor) - which
>worked -
>but since the init script doesn't depend on $remote_fs I had to change
>Can someone help me see what's causing the problem?
> Steffen
>Steffen Grunewald * MPI Grav.Phys.(AEI) * Am Mühlenberg 1, D-14476
>Cluster Admin * --------------------------------- *
>* e-mail: steffen.grunewald(*)aei.mpg.de *
>Condor-users mailing list
>To unsubscribe, send a message to condor-users-request@xxxxxxxxxxx with
>subject: Unsubscribe
>You can also unsubscribe by visiting
>The archives can be found at: