[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [HTCondor-users] cannot create directory `/etc/condor/local/run/condor'

Hi Dan,
Thanks for catching the problem. I haven't tested it yet, but pretty sure you are right because I don't have `local` in the /etc/condor.

Since I am taking over the old shell script from someone who no longer here, I have a question about the local dircetory.

It appears that in our old setup, we have

/etc/condor$ ls
bin  condor_config  condor.csh  condor.sh  etc  include  lib  libexec  local  man  sbin  src
/etc/condor$ cd local
/etc/condor/local$ ls -la

drwxr-xr-x  6 admin root      4096 2012-12-13 16:28 .
drwxrwxrwx 11 root      root      4096 2012-04-04 21:37 ..
-rw-r--r--  1 root      root      1687 2012-04-10 13:09 condor_config.local
drwxr-xr-x  2 admin admin 4096 2012-12-13 16:28 config
drwxr-xr-x  2 admin root      4096 2012-04-10 12:56 execute
drwxr-xr-x  2 admin root      4096 2013-01-10 18:09 log
drwxr-xr-x  3 admin root      4096 2013-01-10 19:00 spool

And we were using 
$CondorVersion: 7.7.4 Dec 21 2011 BuildID: 395684 $
So it wasn't terribly old. 

From our new setup, we have
vagrant@precise32:/etc/condor$ ls
condor_config  condor_config.local  config.d

and config.d is an empty directory.

So there seems to be a lot of files missing. I am wondering if you or anyone has any idea about the difference?
I can create the local subdirecrory (I will once I get the new vm up and running), but not sure there are stuff missing. 
I will also create a vm that installs condor from tar rather than deb. 


On Thu, Jan 10, 2013 at 6:50 PM, Dan Shea <daniel_shea2@xxxxxxxxxxxxxxx> wrote:
Hi John,

Based on the error below and the contents of your /etc/condor directory
You are missing some sub-directories under /etc/condor.

mkdir: cannot create directory `/etc/condor/local/run/condor': No such file or directory

Which is why this FATAL error pops up:

FATAL: Required directory /etc/condor/local/run/condor does not exist, or is not a directory.

Try doing a mkdir -p /etc/condor/local/run/condor

I can't speak as to why the uid:gid on some files is 30101, however if this is all being run as root, you might just want to chown recursively /etc/condor
i.e. chown -R root:root /etc/condor

I hope that helps.

Dan Shea

On 01/10/2013 06:40 PM, John Wong wrote:
Hi. I just installed condor on my Ubuntu 12.04 using the debian package.

I then performed apt-get update and install. 

I wanted to reconfig but condor wasn't running (as indicated by Can't find address for local master), and when I tried to start the service, I got the following errors:

vagrant@precise32:/etc/condor# sudo service condor start
vagrant had uid 1000
mkdir: cannot create directory `/etc/condor/local/run/condor': No such file or directory
chown: cannot access `/etc/condor/local/run/condor': No such file or directory
FATAL: Required directory /etc/condor/local/run/condor does not exist, or is not a directory.

vagrant@precise32:/etc/condor$ ls -la
total 128
drwxr-xr-x  3 30101 30101   4096 Jan 10 23:35 .
drwxr-xr-x 97 root  root    4096 Jan 10 23:21 ..
-rw-r--r--  1 30101 30101 110757 May  9  2012 condor_config
-rw-r--r--  1 root  root    1693 Jan 10 23:24 condor_config.local
drwxr-xr-x  2 30101 30101   4096 May  9  2012 config.d

It is not clear to me where have I gone wrong with my setup. Besides, I noticed that weird 30101 group and user. Any idea? 
In the previous setup, we download the tar.gz and supply --owner and it went fine. 
I am not even able to remove and purge this condor right now. When ubuntu tries to remove condor, it hits the same error.

Any help is appreciated.


Dan Shea - daniel_shea2@xxxxxxxxxxxxxxx
Senior Systems Administrator, West Quad Computing Group
Harvard Medical School
"Charlie was a chemist, But Charlie is no more. For what he thought was H2O, Was H2SO4."

HTCondor-users mailing list
To unsubscribe, send a message to htcondor-users-request@xxxxxxxxxxx with a
subject: Unsubscribe
You can also unsubscribe by visiting

The archives can be found at: