[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[HTCondor-users] Unable to parse single quote in condor_submit config file

Hello All and thanks for any help:
I am experimenting with HTC in a lab as follows:
Homogeneous Windows OS 7 units, no domain - workgroup, UNC file share with Everyone & Guest full permissions.
HTC 7.9.4 x64
I have matlab installed.  I have a simple .m file
that produces a file with Matlab's path so I can test HTC.  From a command prompt, the following command executes properly:
matlab -nosplash -nodesktop -r -wait addpath(genpath('\\Diskstation\Matlab'));cd('\\Diskstation\Matlab\Test');trial;
file://diskstation/MatLab is the UNC path to the shared depository where m-files are kept.
I'm trying to avoid a bat wrapper, and put this in a condor_submit file.  It reads as follows in respect to the arguments:
arguments = -nosplash -nodesktop -r -wait addpath(genpath('\\Diskstation\Matlab'));cd('\\Diskstation\Matlab\Test');trial;
I've referenced http://research.cs.wisc.edu/htcondor/manual/current/condor_submit.html with variants of both the "old" and "new" style for parsing, but when inspecting condor_q -long I am able to inspect the manner in which the arguments are being parsed and it seems incorrect in respect to the single quotes.
Specifically, as I understand the information presented the correct arugment string should read (new style):
"-nosplash -nodesktop '-r -wait addpath(genpath(''\\Diskstation\Matlab''));cd(''\\Diskstation\Matlab\Test'');trial;'"
this is
DblQt-n...             Sngl-r...                         2xSngl\\...                   2xSngl)...2xSignl\\...                            2xSngl...SnglDblQt
I've tried this an many variants with no success.  If anyone has any ideas or references other than the above I would appreciate the direction.
Many thanks,
Of note for many struggling with initial installation with Java errors, the global config file has the following entry that doesn't parse correctly (again specific to Windows):
JAVA_CLASSPATH_DEFAULT = $(BIN) $(BIN)/scimark2lib.jar
This space between $(BIN) $(BIN) parses as a colon and causes issues.
Changing this to a hard coded ; overcomes this:
JAVA_CLASSPATH_DEFAULT = $(BIN);$(BIN)/scimark2lib.jar
and then the following change:
There still doesn't appear to be a curl add-in in the windows deployment.