[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[HTCondor-users] condor_store_cred not updating/adding password on Windows

I have a relatively small Condor pool with about 10 nodes that I use for various processing jobs at my job.  I've had a problem for a while now, starting with Condor v7.4.4 and continuing to Condor v7.8.8, where I cannot get "condor_store_cred" to update or add a credential on Windows.  It doesn't matter if it is a new install or just a user trying to change their password, sometimes the credential will get updated and sometimes it won't.  If I run the command, I get a reply that the "Operation Succeeded", but if I try to submit a job, it will say no credential is stored.  If I then go back and check with "condor_store_cred query", it will say there is no credential stored.  I repeat the process over and over and it will always say the "operation has succeeded", but I can never submit anything because there is "no credential stored".  I've tried Windows XP, Windows XP x64 and Windows 7 with the same results.  I've also tried numerous workstations with the same result.  I just seems to be hit or miss if it will work or not.  I would normally just keep trying until it worked, but some workstations just refuse to work now.  I have no idea what's going on.  Nothing in the logs would indicate a problem either.

I can post more info if needed.

John M.
Systems Administrator