[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [HTCondor-users] condor_store_cred not updating/adding password on Windows

I have not had any problems as you describe (7.x - 7.8.7), but what I have had problems with is using the '-n' option. I have never been able to add a user on a remote submit machine. I am not sure if you are doing this or not. For this case, the user has to sit down at the submit machine, add their credential, and then they can remotely submit jobs. 

I am not sure if would help, but have you tried the '-d' debugging option. Another thing you might try is to delete the user (even though it does not appear to be added) and then try adding the credential again. Most of our machines our now Windows 7, 2008 R2, and some are XP. You might also check the credd service and its log files to see if the service is crashing at all.


- - - - - - - - - - - - - - - - - - - - - - - - - -
Michael O'Donnell

GIS/IT Analyst
Phone: 970.226.9407
Fax: 970.226.9230

United States Geological Survey/BRD
Fort Collins Science Center
2150 Centre Ave., Bldg C
Fort Collins, CO 80526

On Wed, May 22, 2013 at 11:28 AM, May, John <jmay@xxxxxxxxx> wrote:
I have a relatively small Condor pool with about 10 nodes that I use for various processing jobs at my job.  I've had a problem for a while now, starting with Condor v7.4.4 and continuing to Condor v7.8.8, where I cannot get "condor_store_cred" to update or add a credential on Windows.  It doesn't matter if it is a new install or just a user trying to change their password, sometimes the credential will get updated and sometimes it won't.  If I run the command, I get a reply that the "Operation Succeeded", but if I try to submit a job, it will say no credential is stored.  If I then go back and check with "condor_store_cred query", it will say there is no credential stored.  I repeat the process over and over and it will always say the "operation has succeeded", but I can never submit anything because there is "no credential stored".  I've tried Windows XP, Windows XP x64 and Windows 7 with the same results.  I've also tried numerous workstations with the same result.  I jus!
 t seems to be hit or miss if it will work or not.  I would normally just keep trying until it worked, but some workstations just refuse to work now.  I have no idea what's going on.  Nothing in the logs would indicate a problem either.

I can post more info if needed.

John M.
Systems Administrator

HTCondor-users mailing list
To unsubscribe, send a message to htcondor-users-request@xxxxxxxxxxx with a
subject: Unsubscribe
You can also unsubscribe by visiting

The archives can be found at: