[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [HTCondor-users] No daemons are running and attempts to restart condor so far have been unsuccessful

On 3/13/2019 1:05 PM, Jeffrey Tsai via HTCondor-users wrote:
> Hello,
> After some investigation, I found that none of the daemons were running 
> on the Central Manager (using ps aux | grep condor). 
> I tried using condor_master which says that it can't open the log file 
> located at /var/log/condor/MasterLog. Any other command such as 
> condor_restart or condor_off outputs the message: "Can't connect to 
> local master."
> I don't really know what the next steps for troubleshooting would be - I 
> did look at the config files and there seems to be no obvious error. If 
> anyone could offer a solution or guidance it would be greatly appreciated!

Hi Jeff,

At first blush it looks like HTCondor was installed on your machine as 
root, and thus expects to be started as root. My guess is when you tried 
running condor_master, you did so as a regular user, and thus HTCondor 
did not have sufficient permissions (thus the error message about not 
able to write to file /var/log/condor/MasterLog).

How did you install HTCondor?  As root using an RPM or DEB package? If 
so, the RPM or DEB package should have setup your machine to run 
condor_master upon boot-up.   You may want to look at the tail of 
/var/log/condor/MasterLog file to see if it says why HTCondor was shut down.

Hope the above helps,