[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [HTCondor-users] bosco_cluster --test is failing.

Yes, I run the test with the same user in both the cases - from terminal as well as from web interface. 

however, when I looked at the SchedLog while running the test from web, I got the following message :
âââââââââ SchedLod ââââââ
04/10/21 00:17:55 (pid:19664) Number of Active Workers 0
04/10/21 00:18:12 (pid:19664) WARNING: forward resolution of localhost6 doesn't match!
04/10/21 00:18:12 (pid:19664) WARNING: forward resolution of localhost6.localdomain6 doesn't match!
04/10/21 00:18:12 (pid:19664) SetAttribute security violation: setting owner to "cloudcopasi" when active owner is "condor_pool"


I donât know why it is setting âcondor_poolâ as an active user even though the web server is running from âcloudcopasiâ user.
Is there any place where I am missing to set the âactive userâ ?


On Apr 9, 2021, at 4:47 PM, Jaime Frey <jfrey@xxxxxxxxxxx> wrote:

It is odd that the test works completely from the terminal, but only the second part fails from the web interface. I presume both run as the same user account.

The second part is attempting to submit a simple job to the condor_schedd to run on the remote cluster. Itâs calling condor_submit, which is reporting the "ERROR: Failed to commit job submission into the queue.â, which means the condor_schedd is rejecting the submission. The SchedLog file in the Condor log directory should have some additional information about what went wrong.

 - Jaime

On Apr 7, 2021, at 11:13 AM, hasanbaigg@xxxxxxxxx wrote:

Hi All,

I am having a problem in testing a job to bosco cluster. Basically: 

1. From Terminal: When I test a job using âbosco_cluster âtest username@submissionNodeâ, it submits the job and pass the test smoothly. 
2. From Web Interface: When I do the same thing again using the web interface, it just does not pass and I get the following error every time. 
  • bâTesting ssh to user@xxxxxxxxxxxxxxxxx!'
  • b'Testing bosco submission...Failed'
  • b'Submitting job(s). ERROR: Failed to commit job submission into the queue.'
When I run the test from the web interface, I have a backend code written in python which executes the âbosco_clusterâ command via âSubprocess.Popen" method. I have verified already that the problem is not in the âSubprocessâ method. 

I am just wondering if there is anything I am missing in setting up in the HTCondor/bosco configuration files to make it successfully run from the web-interface? 

Please guide me through if I have to check/setup any particular switches (which I might be missing) manually. 

Looking forward to receiving a response. 

HTCondor-users mailing list
To unsubscribe, send a message to htcondor-users-request@xxxxxxxxxxx with a
subject: Unsubscribe
You can also unsubscribe by visiting

The archives can be found at: