[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[HTCondor-users] Java Applications failing to run under Java Universe on Windows

Hi Team,


Currently we have been running Java applications using the vanilla universe via batch scripts. I want to utilise the java universe but I am having trouble running java applications using this submit method.


I have tried both using .class and .jar executables in the submit file but get the same output. The executable is just a “Hello World” application.


This is an example submit file:


universe = java

executable = \\XXXX\XXXX\Main.class

arguments = Main

output = output.txt

error = error.txt

log = log.txt

run_as_owner = True

initial_dir = \\XXXX\XXXX

transfer_executable = True

should_transfer_files = YES

when_to_transfer_output = ON_EXIT



Looking at the log I get the following:


022 (005.000.000) 03/01 17:48:36 Job disconnected, attempting to reconnect

    Socket between submit and execute hosts closed unexpectedly

    Trying to reconnect to slot1_1@XXXX <>


024 (005.000.000) 03/01 17:48:36 Job reconnection failed

    Job not found at execution machine

    Can not reconnect to slot1_1@XXXX, rescheduling job


Investigating the StarterLog.slot1_1 file on the machine:


03/01/21 17:48:36 (pid:6292) About to exec C:\condor\execute\dir_6292\java -classpath C:\condor\bin;C:\condor\bin/scimark2lib.jar;. -Dchirp.config=C:\condor\execute\dir_6292\chirp.config CondorJavaWrapper C:\condor\execute\dir_6292\jvm.start C:\condor\execute\dir_6292\jvm.end Main

03/01/21 17:48:36 (pid:6292) Create_Process(): Failed to extract the extension from file C:\condor\execute\dir_6292\java.

03/01/21 17:48:36 (pid:6292) ERROR: C:\condor\execute\dir_6292\java.exe is not a valid Windows executable

03/01/21 17:48:36 (pid:6292) Create_Process(C:\condor\execute\dir_6292\java, -classpath C:\condor\bin;C:\condor\bin/scimark2lib.jar;. -Dchirp.config=C:\condor\execute\dir_6292\chirp.config CondorJavaWrapper C:\condor\execute\dir_6292\jvm.start C:\condor\execute\dir_6292\jvm.end Main, ...) failed:

03/01/21 17:48:36 (pid:6292) Failed to start job, exiting

03/01/21 17:48:36 (pid:6292) ShutdownFast all jobs.


So it is saying that java.exe is not a valid Windows executable but if I run condor_starter –classad I get the following regarding Java:


JavaVendor = "Oracle Corporation"

JavaVersion = "1.8.0_191"

JavaSpecificationVersion = "1.8"

JavaMFlops = 2598.547363

HasJava = True


I’m kind of out of ideas why it is failing. Any guidance would be appreciated.





This communication (both the message and any attachments or links) is confidential and only intended for the use of the person or persons to whom it is addressed unless we have expressly authorized otherwise. It also may contain information that is protected by solicitor-client privilege. If you are reading this communication and are not an addressee or authorized representative of an addressee, we hereby notify you that any distribution, copying or other use of it without our express authorization is strictly prohibited. If you have received this communication in error, please delete both the message and any attachments from your system and notify us immediately by e-mail or phone. In addition, we note that this communication and its transmission of data have not been secured by encryption. Therefore, we are not able to confirm or guarantee that the communication has not been intercepted, amended, or read by an unintended third party.