[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [HTCondor-users] DAGMan Errors

Hi Takis,

On 25/04/2022 14:07, Takis Angelides wrote:
I did not get a syntax error. I tried what you suggested and got an error message: _CONDOR_DAGMAN_USE_CONDOR_SUBMIT=False: Command not found. from the command line. after submitting:Â_CONDOR_DAGMAN_USE_CONDOR_SUBMIT=False condor_submit_dag -f Schwinger_Wilson_MPS.dag in the command line.

I'm afraid I can't help you there, that command looks perfectly fine (at least on Linux, I have no clue about Windows). However, see below.

I also tried adding to .dag the line CONFIG dagman.config and in this dagman.config file I have the line DAGMAN_USE_CONDOR_SUBMIT = False. This also failed to switch this configuration to False.

What version of HTCondor are you using? The DAGMAN_USE_CONDOR_SUBMIT knob was at some point renamed DAGMAN_USE_DIRECT_SUBMIT (with inverse meaning, and defaulting to True).

Given that the knob defaults to True, I suppose you shouldn't need to set anything (as that would be equivalent to setting the other one to False). However ...

Do you also have an idea about the second error I am seeing about preauthentication failure?

Yes, this looks like its caused by the same bug discussed in this thread: https://lists.cs.wisc.edu/archive/htcondor-users/2022-April/msg00031.shtml, which occurs precisely when using direct submit (which became default in 9.7.0).

What's happening is that HTCondor incorrectly tries to obtain the system credentials, while it is running as a user (it's doing a "direct submission") and should be getting the user's credentials.

You could try working around the issue with DAGMAN_USE_DIRECT_SUBMIT=False, but I suppose that will not work with your inline job definitions.