[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [condor-users] problem with Java execution

In my translet I use java.io.tmpdir, to which I granted write permissions to
Everyone. So when script calls java, it works.

If I wanted to use java universe though, I wouldn't be able to do so on my
master machine, as Condor doesn't detect that I have it installed
(condor_starter.exe -classad doesn't mention Java at all).
I tried to grant write permission to whole disk C for Everyone and restart
Condor, but in still doesn't detect I have java installed.


> Where are you trying to write to... if you use the windows provided temp
dir then, under condor this is not defined explicitly (I think my .net app
then defaulted to the system directory - not pleasant)
> java.io.tmpdir is what java thinks is the temp, dir... try writing this to
console.out under condor and see what it says
> fix this by putting an explicit TEMP=c:\temp in your submit environment or
making sure you are referencing temp directories such as this directly...
> would be nice actually if on windows condor could set the TEMP environment
variable to something like %condor execute dir%\temp\ unless othwerwise
> Matt
> -----Original Message-----
> I set read permission for Everyone on C drive and write on temp directory
> and when I run my script which calls java.exe, it executes ok now.
> However, Condor still doesn't detect that I have java installed on master
> machine. What is the test, that it startd carries out to find if Java is
> installed or not ? If it tries to write anything to disk, it fails, as on
> computer, Everyone has write permission only in temp directory.

Condor Support Information:
To Unsubscribe, send mail to majordomo@xxxxxxxxxxx with
unsubscribe condor-users <your_email_address>