[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] naming conventions

On Sun, 28 Nov 2004 23:24:36 -0600, Derek Wright <wright@xxxxxxxxxxx> wrote:
> i suppose the manual might as well document MaxJobRetirementTime using
> the old style (for consistency).  however, i'd rather people started
> using the FooBar style in general, since that's what they see in job
> ClassAd itself.  so, i'd be happy if all the new settings we added
> were documented with the FooBar style and folks never put "foo_bar" in
> their submit files.

I see, cheers for the explanation. I agree that trying to make what is
visible in the class add the same as the submit docs (at the same time
as maintaining backwards compatibility) is a GoodThing.

If anything I would go with a wholesale 'upgrade' to the docs with the
new style commands (and a big note to the effect that the old style _
approach will still work . In fact for people who search it mightbe a
good idea to include both such as:

ShouldTransferFiles = <YES | NO | IF_NEEDED > 
The ShouldTransferFiles setting is used to define if Condor should
transfer files...

Making the alias a link to an explanation about the reason why.