[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] naming conventions

On Wed, 24 Nov 2004 15:00:07 +0000  matthew hope wrote:

> while it is still in the dev release can I ask why:
> http://www.cs.wisc.edu/condor/manual/v6.7/condor_submit.html
> MaxJobRetirementTime does not follow the foo_bar convention all* the
> other commands use...
> does max_job_retirement_time work?

yes.  like most things in the submit description file, both the legacy
"foo_bar" style works, along with the FooBar style that users actually
see in the "condor_q -long" output (a.k.a., in the "job ClassAd").

> Seems strange (and confusing to end users) to leave it this way...

it seems strange and confusing to use "foo_bar" when you see "FooBar"
in the condor_q output. ;) worse yet are all the cases where you
specify one thing in the submit file and the condor_q output uses a
different name entirely (e.g. 'executable = /some/binary' in the
submit file vs. 'Cmd = "/some/binary"' in the job ClassAd... *sigh*).

maintaining backwards compatibility is a big pain for us, but we go
out of our way to do it.  we don't want folks to have to modify their
submit files after upgrading to a new version unless absolutely
necessary.  some of the most commonly used settings in the submit file
pre-date the existance of classads in Condor at all, and when we first
added the classad attributes, we didn't always use the same names (for
no good reason, it seems).  that's why there's this historical
discrepancy, and why we now support both names (and in some cases,
multiple variations) for the same setting.

i suppose the manual might as well document MaxJobRetirementTime using
the old style (for consistency).  however, i'd rather people started
using the FooBar style in general, since that's what they see in job
ClassAd itself.  so, i'd be happy if all the new settings we added
were documented with the FooBar style and folks never put "foo_bar" in
their submit files.