[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] condor_startd wont run

Eric Medina wrote:

Greg Thain wrote:

hi there! I'm having problems with my condor installation. Im running centOS 3, which is basically RHEL3, on a p4 machine. I configured the machine to be an execute machine and the installation went smoothly.

Now when I run condor_master, I noticed that it was not starting the condor_startd daemon. When I run the daemon manually, it returned the ff error message:
gij: unrecognized option -- `-classpath'
Try `gij --help' for more information.

In general, if you have a problem starting the startd, the best place to start debugging it is by looking at the StartLog on the execute machine in question. Running the startd by hand is a good idea, but sometimes, there are differences in the "by hand" environment, and the one it is booted from. This can lead to confusion in debugging the real problem.
You may need to turn on D_FULLDEBUG to see enough log output.

However, in this case, it looks like you are on to a real problem: When the startd initializes, it runs a small Java program to figure out several attributes about Java to advertise. It looks like java
is misconfigured on your machine. If you run java -classpath . HelloWorld
do you still get the error about classpath?

If you don't want to run Java universe jobs, you can simply leave the JAVA atttribute blank in your condor_config file. Otherwise, you will need to install a Java that understands the -classpath option and handles it correctly.

Condor-users mailing list

i figured it out! im running the wrong java version. I was running java 3.2.3 which doesnt have a classpath option. Version 3.3.2 fixed that.
Thanks anyway.


Condor-users mailing list

i may have spoken too soon. I was able to run startd manually without any error messages. But when i do a "ps ax", it's nowhere to be found. Seems like it exited immediately. I checked the log and the same error message is there:

7/25 19:53:12 ******************************************************
7/25 19:53:12 ** condor_startd (CONDOR_STARTD) STARTING UP
7/25 19:53:12 ** /home/condor/condor-6.6.10/sbin/condor_startd
7/25 19:53:12 ** $CondorVersion: 6.6.10 Jun 13 2005 $
7/25 19:53:12 ** $CondorPlatform: I386-LINUX_RH9 $
7/25 19:53:12 ** PID = 5604
7/25 19:53:12 ******************************************************
7/25 19:53:12 Using config file: /ToonCity3D/etc/TC3D/condor_config
7/25 19:53:12 Using local config files: /home/condor/condor_config.local
7/25 19:53:12 DaemonCore: Command Socket at <>
7/25 19:53:17 ERROR "Required attribute "START" is not defined" at line 255 in file util.C

This is the same error message in the StartLog as before when I was having problems with the --classpath option. I also left the JAVA atttribute blank in the condor_config file. It seems the problem
is not with java. Any idea what the error message may mean?