[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Condor-users] R script with condor

I've had R working with Windows but not tried UNIX. I'm
assuming that since you've used transfer_input_files you
don't use a shared filesystem for the R installation (and
/opt1 sounds local anyway). In this case I think you need
to transfer the whole R installation to the execute host.
I did this by creating a ZIP file of the full R install tree
and uzipped it inside a .bat file on the execute host.
I also made sure that I ran R inside its bin\ directory
on the execute host using this in the .bat file:

unzip -q R.zip
cd R\R-2.2.0\bin
.\Rterm.exe --no-save --no-restore < ..\..\..\SC1mod3.R >

You could do a similar thing with a shell script. Make sure
that you use the DOS only (terminal) version under Windows
if it tries to open a window on the execute hosts a fatal
error is caused and the job will fail.



Dr Ian C. Smith,
e-Science team,
University of Liverpool
Computing Services Department

--On 16 August 2006 10:35 +0200 "a.darrigol" <a.darrigol@xxxxxxxxxxx> wrote:

Hello condor users,

does anybody already succeed to run Rscript with condor on
UNID and/or Windows?

When I tried I have and error saying:
/opt1/R-2.1.1/lib/R/bin/Rcmd: /opt1/R-2.1.1/lib/R/bin/Rcmd:
cannot open

My submit file is the following:
Universe = Vanilla
Executable = /opt1/R-2.1.1/bin/R
Log = condor_log
Output = condor_output
Error = condor_error
transfer_input_files = script.R, /opt1/R-2.1.1/bin/R,
getenv = true
Arguments = CMD BATCH script.R


Cet été, pensez aux cartes postales de laposte.net !

Condor-users mailing list
To unsubscribe, send a message to condor-users-request@xxxxxxxxxxx with a
subject: Unsubscribe
You can also unsubscribe by visiting

The archives can be found at either